Most popular tags

Welcome to Earthwithsun.com, where you can ask questions and receive answers from other members of the community.

Disable Auto-Restart Prompt after Windows Update (in Windows Vista/7)

I've mastered how to disable/delay the Automatic Restart prompt after Windows Update deems it necessary to restart my computer in XP.

But, now I'm using both Windows 7 and Vista and that method no longer works. So far, I have not been able to circumvent the Restart Reminder popup that keeps telling me Restart or Postpone decision for 10 min/1 hour/4 hours (and then popping up again after that delay). Does anyone know how to delay that popup for something like a day (24 hours) or disable it completely?

1 Answer

An easier way than messing around with the registry, or having to run a command after every update:

Open the Local Group Policy Editor:

Start / Run / gpedit.msc

Find the Windows Update settings:

Computer Configuration / Administrative Templates / Windows Components / Windows Update

Edit these 2 settings:

No auto-restart with logged on users for scheduled automatic updates installations: Enabled

Re-prompt for restart with scheduled installations: Enabled, wait period (minutes): 1440

Now you will not be prompted to restart for 24 hours.

You can manually edit the registry using regedit. The best explanation I've found is from the How To Geek here: http://www.howtogeek.com/howto/windows-vista/prevent-windows-update-from-forcibly-rebooting-your-computer/ The link contains automatic ways I'm posting the manual method here:

Open up regedit.exe through the start menu search box or run dialog, and navigate down to the following key, creating new keys if they don’t exist.

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

enter image description here

Create a new 32-bit DWORD value named NoAutoRebootWithLoggedOnUsers and give it a value of 1 to prevent automatic reboot while users are logged on. Delete the value to put things back to the way they were.

Try this command

sc stop wuauserv

see if it stops the nag.

You would need to do this every time you do an update that requires a reboot.

Alternatively, you can go to Start Menu>Run>regedit, on the side click HKEY_LOCAL_MACHINE>SOFTWARE>Microsoft>Windows>CurrentVersion>Run. Once in that folder, right click on the right side of the screen and select New>String Value. Name it "Disable Windows Update Restart Notification" and in the path type in "Cmd.exe sc stop wuauserv" (without the quotes, as those indicate a path).

Other suggestions here, this article is for Vista, but maybe some of the reg hacks will work for 7 http://www.tomstricks.com/how-to-disable-the-annoying-windows-update-restart-prompt-in-windows-vista/

Save this in a .reg file. Run it

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoRebootWithLoggedOnUsers"=dword:00000001