Most popular tags

Welcome to Earthwithsun.com, where you can ask questions and receive answers from other members of the community.

Why can't Chrome load a web page? ERR_NAME_NOT_RESOLVED

Chrome gives this error, yet I can ping the server!

The server at www.odesk.com can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network. Check your Internet connection. Check any cables and reboot any routers, modems, or other network devices you may be using. Check your DNS settings. Contact your network administrator if you're not sure what this means. Try disabling network prediction. Go to the Chrome menu > Settings > Show advanced settings... and deselect "Predict network actions to improve page load performance." If this does not resolve the issue, we recommend selecting this option again for improved performance. Allow Chrome to access the network in your firewall or antivirus settings. If it is already listed as a program allowed to access the network, try removing it from the list and adding it again. If you use a proxy server... Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Chrome menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN". Error code: ERR_NAME_NOT_RESOLVED

$ ping odesk.com

Pinging odesk.com [64.41.140.207] with 32 bytes of data:
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47

Ping statistics for 64.41.140.207:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 103ms, Maximum = 103ms, Average = 103ms

$ ping www.odesk.com

Pinging e5489.g.akamaiedge.net [23.199.64.63] with 32 bytes of data:
Reply from 23.199.64.63: bytes=32 time=665ms TTL=52
Reply from 23.199.64.63: bytes=32 time=389ms TTL=52
Reply from 23.199.64.63: bytes=32 time=541ms TTL=52
Reply from 23.199.64.63: bytes=32 time=578ms TTL=52

Ping statistics for 23.199.64.63:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 389ms, Maximum = 665ms, Average = 543ms

I restarted Chrome, and I also disabled my network adapter and re-enabled it. I also ran ipconfig /flushdns. 'Predict network actions to improve page load performance' is already off.

1 Answer

You can try to disable Google Chrome's DNS Prefetching: Settings > Show Advanced Settings > Privacy and disable the option Predict network actions to improve page load performance.

Alternatively, flush Chrome's DNS cache.

enter image description here

More details here.