Vista stuck on “Calculating” when deleting or moving files

Vista stuck on “Calculating” when deleting or moving files

Sometimes when I try to delete or move files, the window reporting the operation progress gets “stuck” in the Time remaining: Calculating phase and never continues.

When I press Cancel in the progress window, the window title changes to “Canceling” and stays at that.

Process Explorer does not show any significant CPU or disk activity for Explorer.exe or any other process.

Is this some kind of known problem? Is there any solution?

(I am using Vista x64 with SP2)

1 Answer

If you are trying to move large numbers of files at once, then Windows does spend time up front gathering information on all of the files you are trying to move/copy/delete and spends time figuring out how long it’s going to take. It is one of the most irritating parts of Windows in that it does not handle file operations with many files at once very well. This delay will also only increase the more if either the source or the destination is a slower location, such as a CD/DVD, an external network share over a slow network connection or an external USB drive.

If you are getting this problem with only trying to move/copy/delete a single file or a couple of files, then you may have an issue with corrupted Windows core functionality, or perhaps a device driver which is not fully compatible with Vista.

I have noticed this behaviour, too. For me, the reason was clear: Windows was generating thumbnails for the video files that I actually wanted to delete. Thus, the deletion failed respectively stalled while the file was read for thumbnails.

EDIT: Oops, I just recognized that you wrote “deleting or moving files” not “deleting movie files”. Haha. Sorry. But maybe my answer fits anyway.

The only solution I’m aware of is to turn off or bypass your trash. When you ‘delete’ a file you are really moving it into another folder, typically C:RECYCLER. If you want to permanently delete one or more files, press Shift + Delete. This avoids the recycle bin entirely, but just for this one operation.

You can disable the recycle bin by:

  1. Right click on the Recycle Bin.
  2. Select Properties and then select the General tab.
  3. Check the “Do not move files to the Recycle Bin” option.
  4. Select OK.

Leave a Reply

Your email address will not be published. Required fields are marked *